Главная / Оповещения / Еще несколько уязвимостей обнаружены и устранены в популярном менеджере лицензий

Еще несколько уязвимостей обнаружены и устранены в популярном менеджере лицензий

Центр реагирования на инциденты информационной безопасности промышленных инфраструктур «Лаборатории Касперского» (Kaspersky Lab ICS CERT) выявил множественные уязвимости в службе hasplms, которая является частью продуктов HASP SRM, Sentinel HASP и Sentinel LDK производства компании Gemalto.

Выявленные уязвимости относятся к следующим типам: удаленный отказ в обслуживании (Denial of Service), NTLM Relay, переполнение буфера стека (Stack Buffer Overflow), удаленное включение веб-интерфейса администрирования (Remotely enabling web admin interface), произвольное чтение памяти и возможность удаленного выполнения кода (Arbitrary Memory Read and Possible Remote Code Execution).

Уязвимые продукты широко используются для управления и контроля лицензий в различных областях бизнеса: автоматизированных системах управления технологическим процессом (АСУ ТП), финансовых организациях, банковских структурах, и т.д. Уязвимая версия драйвера может быть установлена в автоматическом режиме на произвольную систему путем подключения легитимного лицензионного USB-ключа.

Уязвимая служба hasplms открывает порт 1947/tcp, который имеет доступную web-среду администрирования, включенную по умолчанию. Злоумышленник может скрытно удаленно включить или выключить web-среду администрирования. Возможна удаленная эксплуатация всех указанных ниже уязвимостей как с включенной, так и с выключенной web-средой администрирования.

Kaspersky Lab ICS CERT сообщил об уязвимостях производителю, который не выпустил уведомление об их исправлении. Если у вас установлены Sentinel LDK (RTE) Run-Time Environment версий v2.10 – 7.50, рекомендуется обновить Sentinel LDK RTE до последней версии (v 7.6), которая была выпущена 27 июля 2017 года.  Данное обновление можно скачать на официальном сайте загрузок Sentinel.

Kaspersky Lab ICS CERT присвоил уязвимостям следующие номера CVE:

  1. CVE-2017-12818
    Переполнение стека в нестандартном XML-анализаторе ведет к удаленному отказу в обслуживании.
  2. CVE-2017-12819
    Удаленное манипулирование программой обновления языковых пакетов ведет к атаке NTLM-relay на системного пользователя.
  3. CVE-2017-12820
    Произвольное чтение памяти из контролируемого указателя памяти ведет к удаленному отказу в обслуживании.
  4. CVE-2017-12821
    Повреждение памяти может привести к удаленному выполнению кода.
  5. CVE-2017-12822
    Web-интерфейс менеджера лицензий включен в конфигурации по умолчанию. В случае отключения возможно его удаленное включение.