Главная / Новости / Критические уязвимости в промышленных коммутаторах WAGO

Критические уязвимости в промышленных коммутаторах WAGO

В промышленных коммутаторах WAGO 852-303, 852-1305 и 852-1505 обнаружены опасные уязвимости. Успешная эксплуатация этих уязвимостей позволяет удаленно скомпрометировать управляемый коммутатор, что может привести к нарушению связи и root-доступу к операционной системе устройства.

Наиболее опасные уязвимости, получившие оценку в 9,8 баллов по шкале CVSS v.3, вызваны использованием жестко закодированных данных в прошивке коммутатора.

Первая уязвимость (CVE-2019-12550) связана с использованием жестко закодированных учетных данных. С помощью них злоумышленник может получить доступ к операционной системе коммутатора с правами root и произвести различные вредоносные манипуляции: изменить настройки коммутатора, удалить приложения либо внедрить вредоносный код.

Вторая уязвимость (CVE-2019-12549) обусловлена использованием закрытых ключей SSH, жестко закодированных в прошивке коммутатора. Получив доступ к этим ключам, атакующий может нарушить коммуникации или скомпрометировать устройство. При этом, пользователи не могут перегенерировать SSH-ключи, и все коммутаторы используют один и тот же ключ.

Кроме того, в этих продуктах используются устаревшие сторонние компоненты BusyBox UNIX и GNU C Library (glibc) с множественными уязвимостями.

Все перечисленные уязвимости исправлены производителем в новых версиях прошивок:

  • для WAGO 852-303 – 1.2.2.S0;
  • для WAGO 852-1305 – 1.1.6.S0;
  • для WAGO 852-1505 – 1.1.5.S0.

Источники: ICS-CERT, CERT VDE