Главная / Новости / Новая уязвимость в ПЛК Schneider Electric Modicon

Новая уязвимость в ПЛК Schneider Electric Modicon

В программируемых логических контроллерах (ПЛК) и контроллерах автоматизации (PAC-контроллерах) Schneider Electric Modicon обнаружена уязвимость CVE-2019-6819, которая позволяет атакующему вызвать отказ в обслуживании устройства. Эта уязвимость связана с некорректной проверкой исключительных ситуаций и может быть проэксплуатирована путем отправки специально сформированного кадра Modbus на уязвимое устройство

Уязвимость затрагивает следующие продукты:

  • Modicon M340 (с версиями прошивки до 3.01);
  • Modicon M580 (версии до 2.80);
  • Modicon Quantum (все версии прошивки);
  • Modicon Premium (все версии прошивки).

Выявленная уязвимость устранена производителем в новых версиях прошивок для контроллеров серии Modicon M340 и Modicon M580 – 3.01 и 2.80, соответственно. Так как решение Modicon Quantum исчерпало срок службы и выведено из продажи, Schneider Electric рекомендует пользователям перейти на актуальный продукт — Modicon M580 ePAC.

Для снижения рисков, связанных с эксплуатацией указанной уязвимости необходимо настроить сегментацию сети и использовать межсетевой экран для блокировки несанкционированного доступа к порту 502 / TCP.

Источники: ICS-CERT, Schneider Electric