01 марта 2019

KLCERT-19-004: UltraVNC Heap-based Buffer Overflow

Vendor

UltraVNC

Timeline

Timeline

  • Kaspersky ICS CERT advisory updated

    26 января 2024

  • Kaspersky ICS CERT advisory published

    01 марта 2019

  • Vendor releases patch

    февраля 2019

  • Vulnerabilities reported

    17 января 2019

Description

An attacker controlling a device with the UltraVNC Server running can perform remote code execution on the client devices to cause a denial-of-service condition, modify system's data and/or obtain sensitive information.

Exploitability

Remotely

Attack complexity

Low

User interaction

None

Attack Conditions

User interaction is required: user connection to the attacker’s malicious server through the vulnerable VNC client is required.

Impact

Successful exploitation of this vulnerability could allow an attacker to execute arbitrary code.

Existence of exploit

PoC

Affected products

UltraVNC before 1.2.2.4

Mitigation

Vendor mitigation

Update UltraVNC to 1.2.2.4 or newer

Kaspersky Lab publishes information on newly identified vulnerabilities in order to raise user awareness of the IT security threats detected. Kaspersky Lab does not make any guarantees in respect of information received from vendors of products in which vulnerabilities have been identified, which is included in the following sections of the advisory: Affected Products, Vendor Mitigation.

Timeline

  • Kaspersky ICS CERT advisory updated

    26 января 2024

  • Kaspersky ICS CERT advisory published

    01 марта 2019

  • Vendor releases patch

    февраля 2019

  • Vulnerabilities reported

    17 января 2019