Главная / Новости / Множественные уязвимости в Wecon PI Studio

Множественные уязвимости в Wecon PI Studio

В HMI-решении PI Studio компании WECON Technology обнаружены множественные уязвимости, две из которых являются критическими. Успешная эксплуатация уязвимостей может привести к удаленному выполнению кода и раскрытию важной информации, в том числе в контексте администратора. Проблема затрагивает решения PI Studio HMI (версии 4.1.9 и предыдущие) и PI Studio (версия 4.2.34 и более ранние).

Наиболее опасными являются уязвимость переполнения буфера CVE-2018-14818 и уязвимость CVE-2018-14810, связанная с записью за границами буфера (out-of-bounds write). По шкале CVSS v.3 эти уязвимости получили оценки 9,8 и 8,8 соответственно. Обе бреши могут привести к удаленному выполнению кода, и в случае с CVE-2018-14810 — выполнению кода в контексте администратора.

Еще одна брешь в безопасности (CVE-2018-17889) связана с использованием в WECON PI Studio уязвимого к атаке XXE (XML eXternal Entity) XML парсера, из-за чего злоумышленник может получить доступ к важной информации.

Кроме того, в PI Studio отсутствует корректная проверка данных, вводимых пользователем, что может привести к чтению данных за пределами выделенного объекта (CVE-2018-14814).

В настоящее время производитель работает над исправление указанных уязвимостей.

Источник: ICS-CERT